Pl 360 no audio


ppasteur@...
 

Hey folks, I tried this before but it was under someone else's topic. Not sure if it was flat missed, or if no one has any info about it. I thought I would give it one more try before I gave up. 


I have been meaning for sometime to consult the collective wisdom of the group on an issue that I have with my PL-360. I remember reading that several members of the group got this radio. I am hoping that maybe someone had the below problem and figured out how to fix it!


I have had the PL-360 for what seems like a couple of years now. Gary helped me out by making up both a MW and LW 7.5" Amidon antennas for the radio. I don't listen to it that often due to lack of time, but have had many hours of enjoyment using both of the antennas over the years that I have had it.


Until just recently that is. One day a few weeks ago I tried to use the radio, but,  I now have no audio out of the thing. Neither through the speaker nor  any of several sets of headphones through the earphone jack. It is clearly tuning. It gets many stations and the signal strength and noise meters work fine. In fact everything seems to be working just fine... except one. No audio!


I have made sure that I have fully charged batteries in it...and used good quality alkaline batteries. I have cleaned the jack using deoxit (used  a headphone mini plug and worked around the jack many times).

Still no audio. I have let it sit with no batteries in it for days and retried.. to no good effect!


Is there a master reset somewhere that I could try resetting the microprocessor with?


Does anyone have any suggestions for additional troubleshooting or repair steps. OR, is it just time to get a new one?


Thanks for any and all advice or suggestions!!,

Phil 


Rik
 

I love my digital  Tecsun radios and I have a lot of them but unfortunately they do have a reletively high failure rate where they do something completely different than what the controls are set for. Some years ago I took my PL-360 with the two Loop Stick antennae Gary made for me to the coast of Maine, and no matter what I did I could not switch  the radio to LW. No problem after I got home though. I bought a second PL-600 and CR-1100 because they shut off or turn them selves on all by them selves. Some times they fix them selves for awhile, and other times the  digital Tecsun just dies never to work again. My newer PL-310ETM only tunes with ETM or from the Memory for awhile now. It will not tune to the next frequency. Since you have the larger ferrite antennae, I'd consiter  getting a couple more PL-360 radios to go with them. - FARMERIK


ppasteur@...
 

Thanks Farmerik!

I guess I should just write it off. I thought maybe the master Gary may have seen this issue and maybe had a fix.

If not, you are right, it is time to just bite the bullet and pick up another PL 360. The thing about that is, other then the great antennas that Gary made for me to use with it... I am not a fan of the radio. I particularly do not much like the form factor.


Anyway, thanks again for the response!


Phil


Gary DeBock
 

Hello Phil,
 
<<<    I guess I should just write it off. I thought maybe the master Gary may have seen this issue and maybe had a fix.    >>>
 
Sorry for delayed communication, Phil-- investigation, testing and modification of the new CC Skywave have been taking up most of my limited hobby time this week.
 
If both the speaker and headphone jack of your PL-360 have no audio then your audio amplifier IC chip has probably failed, leaving you without any good repair options. You could pay for a repair which would probably cost more than a new PL-360, or attempt to find a junk PL-360 on eBay that might have a good audio amp IC (a very long shot), after which you would need to track down a technician ready, willing and able to do a tricky circuit board swap for you under extremely tight conditions (an even longer shot). Given the low purchasing cost of a new PL-360 your best option would be to bite the bullet and spring for a new one, bearing in mind that the 7.5" plug in loopsticks transform the humble model into a  paragon of DXing sensitivity.
 
73, Gary DeBock (in Puyallup, WA, USA)
     
 
 
 

-----Original Message-----
From: ppasteur@... [ultralightdx]
To: ultralightdx
Sent: Tue, Dec 30, 2014 10:07 am
Subject: [ultralightdx] Re: Pl 360 no audio

 
Thanks Farmerik!
I guess I should just write it off. I thought maybe the master Gary may have seen this issue and maybe had a fix.
If not, you are right, it is time to just bite the bullet and pick up another PL 360. The thing about that is, other then the great antennas that Gary made for me to use with it... I am not a fan of the radio. I particularly do not much like the form factor.

Anyway, thanks again for the response!

Phil


Rik
 

I waited awhile hoping someone else would have a better answer.- FARMERIK