Re: Unable to select LW on Tecsun PL-606


Al McDivitt
 


 Hi STeve
 
Press the MW button changes the tecsun PL-606 for MW to LW and then back
 
From the manual
MW/LW ATS: Press the [MW] button to select MW/LW band,
 
Hope this helps, Enjoy the new radio
 
73 Al McDivitt  VK4BL
 
 

----- Original Message -----
Sent: Wednesday, September 23, 2015 8:02 AM
Subject: [ultralightdx] Unable to select LW on Tecsun PL-606

 

First of all, Hi guys, I'm a newbie on ultralightdx and I come to the forum from a background of Vintage Wireless of some 39 years. In recent months I have become interested in portable sets and have morphed from that to sets that include SW. As a result my interest in SW has grown - I know very little at this point - and I have acquired a few sets with SW capability including a Zenith Trans Oceanic Royal D7000Y and a Sony Earth-Orbiter 5090 - both great sets by the way. Going a stage further and wanting to see what a more modern set can do I bought a Tecsun PL-606. Yes I realise it's a just a cheapy set and more just a bit of fun than a 'proper' SW set, but anyway I'm enjoying scanning SW stations and just generally plodding along learning more about SW for now. However, there's one problem in that I cannot select LW on it. Following the instructions in the operation manu al, with the set in 'power off' mode I press the 'MW' button and as told I can then use it to toggle between 'LW OFF' and 'LW ON' appearing in the display. So far so good, that's what is supposed to happen, so I select 'LW ON' and within a second or so the set simply returns to 'power off' mode, no sign of LW either in the display or sound wise; the set is simply 'off'. I've tried holding the MW button down for different time periods etc but to no avail. Can someone with a PL-606 please tell me exactly what they do to select LW?  Thanks.


Join main@UltralightDX.groups.io to automatically receive all group messages.