Re: PL-606


jaypolicow@snet.net <jaypolicow@...>
 

I also would prefer manual speed setting but the auto speed select can work well...I am pretty happy with the way it works in the PL-310...it usually seems pretty predictable and natural.

Jay

--- In ultralightdx@..., "gkinsman1" <gkinsman@...> wrote:



Hi Jay,

On my PL-380, I was able to put most of the MW band frequencies into memory, to allow me to simulate 10 kHz tuning (each click of the wheel moves exactly one MW channel). There are not quite enough memories to cover the whole MW band. Perhaps a similar strategy is possible on the PL-606.

I'd much prefer that Tecsun provide a button to select 1 kHz or 10/9 kHz tuning via the wheel/knob. I believe the Eton E10 has this. The smaller E100 has 1 kHz tuning by knob and 10/9 kHz tuning by buttons. Both of these radios were built by Tecsun.

Regards,
Gary

--- In ultralightdx@..., "jaypolicow@" <jaypolicow@> wrote:

I got my PL-606 yesterday and initial tests seem pretty good, especially on SW and FM. AM appears to approximately match my PL-310 along with that nasty muting.

The only problem I'm having is with the two-speed tuning...it seems much harder to get it to kick into fast speed compared with my other two-speed models (like the PL-310). I crank and crank and crank and it's moving only 1 KHz at a time, but sometimes (not always) if I quickly reverse direction then resume spinning the dial it will go to fast speed. But if I then pause for a split second..back to slow speed... makes it very tough to get from here to there...lots of pushing of that thumb wheel.

Has anyone else dealt with this or is it a quirk of my particular sample?

Jay

Join main@UltralightDX.groups.io to automatically receive all group messages.